Jump to content

How to dodge RageMP crashes

Did this method work for you?  

60 members have voted

You do not have permission to vote in this poll, or see the poll results. Please sign in or register to vote in this poll.

Recommended Posts

Did your RageMP die of a sudden cardiac arrest and you don't know what the hell happened? is the new EAC making your RageMP experience a pain in the ass? this step by step guide MIGHT help you play just fine with your mods and sanity intact.


  1. Go to RAGEMP\server-files\client_packages\game_resources (create the folders if they don't exist)
  2. Create a file named "allow_user_game_resources.txt" in that folder, open it and type "1" then save it
  3. Go to RAGEMP\server-files and run ragemp-server.exe, grant firewall access if needed
  4. Open RageMP's client, use manual connect, and connect to IP: Port: 22005
  5. Wait for the game to boot, you will spawn with a default MP character, this means you're now connected to the server you just hosted on your own PC
  6. Press F1 and use manual connect once again, connect to IP: Port: 22005
  7. If you see "Loading server resources" for a long time, don't panic, RageMP is downloading the server assets, it will take a while depending on your internet speed, and this will be a one-time only download process, it'll be instantaneous for the next logins
    (Direct IP server assets will be downloaded to "RAGEMP\client_resources\eb2a00104e081555cd1f62c318c273fa")
  8. Once the download is complete (first-time only), you will be greeted with the login screen and you can connect and play


Fix RageMP launcher crashing on "Validating server assets":

  1. Download the latest version of Process Explorer from HERE, extract it to a folder and run procexp64.exe as Administrator
  2. Run updater.exe to boot up the RageMP launcher
  3. In Process Explorer scroll down and find ragemp_v.exe and all of it's sub UI processes
  4. Right click on each one and set priority to real time
  5. Connect to the server as you normally would


Force your way in - also (might)work if crashing on "Validating server assets":

  1. Open up RageMP's launcher, connect to GTA World, if you see it trying to download assets and not progressing, close it (Alt+F4) or if it crashes on Establishing connection or Validating assets, close it (Alt+F4) and move onto the next step
  2. Open up RageMP's launcher again, then fully disconnect your PC from the internet (Make sure you don't have Rockstar Launcher running)
  3. Click on GTA World, wait for Rockstar Launcher to open, connect your PC to the internet again
  4. Click the button on top of Rockstar Launcher that says "Restart to go online"


Optional step:

  1. Run task manager, find PlayGTAV.exe and all of ragemp_game_ui.exe instances under the details tab, right click on them, Set Priority -> Realtime
Edited by BadassBaboon
  • Upvote 4
Link to comment

I don't know if it's just me but once I follow all the steps to the letter and connect to, I'll crash at the end of 'Finishing Handshake'.

I then ended my server and tried to just do connect play.gta.world like normal and it was fine.

Link to comment
On 3/1/2022 at 7:09 AM, BadassBaboon said:

Optional step:

  1. Run task manager, find PlayGTAV.exe and all of ragemp_game_ui.exe instances under the details tab, right click on them, Set Priority -> Realtime

this alone helps me tremendously thanks

Link to comment
  • 4 weeks later...



This works better. I don't see any option in my Rockstar launcher to go online, so it never really worked. But with this, it'll first start steam and during the process, you can easily turn on back internet and let RAGE start everything straight into online!


AND You can skip first step. Just start rage, let it load and turn off internet > Start from there


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...