Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal

Rockstar Launcher RAGE MP not working at launch


Recommended Posts

Hello

 

I'm currently using Rockstar Launcher (i know it's shit but I got the game for free and kept using it) for my RAGE MP.

 

Everything works, and the server downloads all the assets as regular.

6UAQ9wc.png

 

When I launch RAGE MP it opens as usual, and I connect to the GTA W server as regular. 

 

I wait maybe 10-15 seconds after connecting to the GTA W server and this pops up:

AoyCv7S.png

 

Then I wait another 5 seconds and the game ends up closing out on me automatically as soon as the Rockstar Game Connection pops up. I've tried literally everything, every thread I could find, every solution I can come up with. Deleted the game, uninstalled it, reinstalled it, restarted my computer, etc.

hsRpJtp.png

 

I've been playing for the past 2 days with no problem, and as I was IG my game crashed and I've been having this problem ever since. I don't have any mods, or any extra files in my game, it's as bare boned as it'll be.

 

It keeps closing out as soon as the Rockstar Loader appears smh. Anyone who can help is great appreciated.

Link to post

Hello there, I have a guide based off of this issue, if that doesn't work, tag me in #support and we'll figure it out! 

1) Close out of everything Game related on your computer! (Clients / Applications!).
2) Double click Rage Multiplayer, press yes when prompted to run as Administrator.
3) Once the RageMP Server Selection Screen pops up, let it hang out there. You can minimize it, if you'd like!
4) Right click RageMP, toggle to 'Run as Administrator', press yes when prompted to run as Administrator.
5) Wait a few seconds, and a second window should pop up!
6) Right click the server of your choosing (I recommend GTA World! >:D) and press connect. Do this while the other window runs in the background! 

Let me know in support if this works or not.

  • Thanks 1
Link to post

Shoutout to Geo helped me figure it out. I basically played single player for like 10 minutes then hopped on RageMP right after and bam. Easy as that.

 

you can l&a this please 

  • Upvote 1
Link to post
On 2/16/2021 at 5:34 PM, Geo0004 said:

Hello there, I have a guide based off of this issue, if that doesn't work, tag me in #support and we'll figure it out! 

1) Close out of everything Game related on your computer! (Clients / Applications!).
2) Double click Rage Multiplayer, press yes when prompted to run as Administrator.
3) Once the RageMP Server Selection Screen pops up, let it hang out there. You can minimize it, if you'd like!
4) Right click RageMP, toggle to 'Run as Administrator', press yes when prompted to run as Administrator.
5) Wait a few seconds, and a second window should pop up!
6) Right click the server of your choosing (I recommend GTA World! >:D) and press connect. Do this while the other window runs in the background! 

Let me know in support if this works or not.

@Geo0004Hey mate! Thanks a lot for the amazing guide! You saved my nerves 😄 Do I have to do all of these steps every single time I want to connect to the server or only the first time?

 

Do you recommend keeping my antivirus off or paused - or the antivirus is not the issue?

 

 

Cheers!

Link to post

Hello there, David! 

Your computer is constantly sourcing files in order to Launch your game. You are making it hard on your computer when the same Application is sourcing files and displaying the game data. By separating it, you're allowing one window to Display the Game, and the other in the background is helping grab the files as needed! As you play more, your computer will find ways to source the files easier, so you won't have to do it every time! 

As for Firewalls, if RageMP Works with them on, perfect! If not, just disable the Firewall for RageMP, disabling it totally is not needed.

I hope this helps, have a great day!

Your friend, 

Geo

Link to post

Hey @Geo0004!

 

Thanks for the help once again! I am using Kaspersky antivirus. Even tough I added RAGE directory in exclusions - it did not work. I will try to pause Kaspersky for 5 minutes - while I log in the server and then all should be fine.

 

Why is it so difficult at the moment to access game process? Is it because of the new RAGE version?

 

Have a nice day!

Link to post

Hey again! 

Unlike most Applications on your computer (Chrome, internet explorer, Direct Games), RageMP uses an updater.exe file, which runs the source code in your Command Prompt before it decides whether or not it wants to launch. Sometimes when using an updater, your computer will reject it, trying to protect you from a possible Virus. That is the main issue I face when I am helping others! 

The chances of the game loading are not in your hand, or not even in your computer's hands. Your computer will always want to deliver what the User (you) has selected. Having said that, RageMP sorts through a lot of mod / dlc / extra packs that are not in GTA V, so the validity of those files also come into play!
 

  • Upvote 1
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...