Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
arandomgamer

GPU usage and FPS randomly drops

Recommended Posts

Sting McGee    11
Posted (edited)
54 minutes ago, arandomgamer said:


https://www.userbenchmark.com/UserRun/32471611

My CPU should be fine.

A Ryzen 5 2600 isn't going to bottleneck a RTX 2060S ( or any card at that resolution/FPS for that matter ). It's an issue of optimisation. If I had to guess the game is poor at using multiple cores and the mods don't help

What are your MSAA, Post FX and grass quality graphical settings at in-game? Through heavy experimentation, I found this is where some of the optimization issue is with GTA as a whole, even with decent PC hardware. I found that turning these down to Normal or High help to decrease massive FPS drops. GTA is terribly optimized, so it's just a matter of tweaking the settings to where you can live with it.

Edited by Cellestine

Share this post


Link to post
On 10/9/2020 at 7:47 PM, Cellestine said:

What are your MSAA, Post FX and grass quality graphical settings at in-game? Through heavy experimentation, I found this is where some of the optimization issue is with GTA as a whole, even with decent PC hardware. I found that turning these down to Normal or High help to decrease massive FPS drops. GTA is terribly optimized, so it's just a matter of tweaking the settings to where you can live with it.


So the thing is, when my GPU is used at close to 99% the FPS is fine. The issue here is that some zones cause it to not be used properly ( south Los Santos in particular ).

My MSAA is 4x, grass is Medium, post FX is probably high.

Like this isn't my PC not being able to handle the game, it's the game not being able to handle my PC. I'm not getting any cap, the GPU usage just goes from 98% to 60% for no reason, and the FPS drops accordingly. This would normally be chalked up to poor optimisation.

I'm far from a techwiz, but since some people don't have the issue I imagine the game is very limited in multicore usage, so the people who have a 5 GHz CPU are not having as many issues, as single core performance matters way more.

Share this post


Link to post
bncal    25

Hey I have a similar problem, but in my case the cpu (ryzen 3 3200g) goes from 80% to 100% and the gpu (Rx 570 8gb) should be around the 60%. The problem is when the cpu goes mad (100%) my game can't load roads and buildings, vehicles and players (so I can kill or destroy player's vehicle). This is so weird because it's a new issue for me. I gotta say, gta online works fine. 

 

 

Share this post


Link to post
2 hours ago, bncal said:

Hey I have a similar problem, but in my case the cpu (ryzen 3 3200g) goes from 80% to 100% and the gpu (Rx 570 8gb) should be around the 60%


That's a CPU bottleneck, yeah. GTAW is probably worse optimisation wise than retail GTA because of all the mods and extra players.

 

In my case though it doesn't look like a CPU bottleneck, because the CPU is nowhere near 100%, so that's the source of my confusion.

Share this post


Link to post
bncal    25
49 minutes ago, arandomgamer said:


That's a CPU bottleneck, yeah. GTAW is probably worse optimisation wise than retail GTA because of all the mods and extra players.

 

In my case though it doesn't look like a CPU bottleneck, because the CPU is nowhere near 100%, so that's the source of my confusion.

So how I can fix it? Gotta change CPU?

Share this post


Link to post
4 hours ago, bncal said:

So how I can fix it? Gotta change CPU?

I had the same issue, yeah, CPU upgrade worked for me.

Share this post


Link to post
bncal    25
2 minutes ago, SteveHastingson said:

I had the same issue, yeah, CPU upgrade worked for me.

Anyway I was planning to buy another cpu, ryzen 5 3600. Should I do a bios update? MOBO is Gigabyte Technology Co. Ltd. B450 AORUS M (AM4) and I already did a bios udpate to use the current cpu I have (ryzen 3 3200g). 

Share this post


Link to post
2 hours ago, bncal said:

Anyway I was planning to buy another cpu, ryzen 5 3600. Should I do a bios update? MOBO is Gigabyte Technology Co. Ltd. B450 AORUS M (AM4) and I already did a bios udpate to use the current cpu I have (ryzen 3 3200g). 


BIOS updates rarely cause a notable improvement in performance.

 

That being said Ryzen 3 3200g came out in 2019 so I'm not sure how it's getting bottlenecked by GTA.

 

Share this post


Link to post
bncal    25
6 hours ago, arandomgamer said:


BIOS updates rarely cause a notable improvement in performance.

 

That being said Ryzen 3 3200g came out in 2019 so I'm not sure how it's getting bottlenecked by GTA.

 

I did the bios update because the cpu was not compatible with my mobo, not to increase performances xd anyway I'll see this week what I can do. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...